Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72893 - intel_backlight/brightness has no effect when modified on CometLake-H GT2

Attached to Project: Arch Linux
Opened by Moody (Moody) - Wednesday, 01 December 2021, 16:59 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 07 February 2022, 07:04 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I have a laptop Lenovo Legion Y7000P2020H, while it's possible to adjust the backlight
in discrete GPU, however, when set to "Hybrid" mode in BIOS, the `intel_backlight/brightness`
has no effect on the actual screen backlight. There's no hardware brightness key on the keyboard.

Details:

uname -a:
> Linux arch 5.16.0-rc3-1-mainline #1 SMP PREEMPT Mon, 29 Nov 2021 21:15:09 +0000 x86_64 GNU/Linux

/sys/class/backlight/intel_backlight/max_brightness: 26666
/sys/class/backlight/intel_backlight/bl_power: 0 (When set to 1, the backlight turns off)
/sys/class/backlight/intel_backlight/brightness: 1333 (Has no effects whenever set to a non-zero value, zero causes a blackscreen)
/sys/class/backlight/intel_backlight/type: "raw"

Kernel Parameters: `root=/dev/mapper/archroot rw resume=UUID=6514112c-9b82-4b82-b2a8-2bd2b372f2ae loglevel=15`

Tried parameters:

i915.enable_dpcd_backlight=0
i915.enable_dpcd_backlight=1
acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native

Additional info:
* package version(s)
Name : linux-mainline
Version : 5.16rc3-1

* config and/or log files etc.
Attached

* The brightness adjustment works in Windows, so it's probably not a hardware problem.
   info.zip (97.3 KiB)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 07 February 2022, 07:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  2022-01-28: A task closure has been requested. Reason for request: This has been fixed in a newer kernel version, which introduced a new module named `nvidia_wmi_ec_backlight`.
Comment by Moody (Moody) - Thursday, 02 December 2021, 00:54 GMT
Added an attach with kernel parameter drm.debug=14
Comment by Moody (Moody) - Sunday, 05 December 2021, 08:31 GMT
  • Field changed: Percent Complete (100% → 0%)
I tried for the current Linux kernel, which is `Linux arch 5.15.5-arch1-1 #1 SMP PREEMPT Thu, 25 Nov 2021 22:09:33 +0000 x86_64 GNU/Linux
` and the problem exists as well.

Loading...