Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72873 - [slim] fails to build with newer gcc

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Monday, 29 November 2021, 14:09 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 19 December 2021, 04:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/build/slim/src/slim-1.3.6/panel.cpp:51:27: error: ordered comparison of pointer with integer zero (‘GC’ {aka ‘_XGC*’} and ‘int’)
51 | if (WinGC < 0) {
| ~~~~~~^~~
/build/slim/src/slim-1.3.6/panel.cpp: In member function ‘bool Panel::OnKeyPress(XEvent&)’:

This has been fixed upstream, see:
- https://github.com/iwamatsu/slim/issues/14
- https://github.com/iwamatsu/slim/pull/15/commits/86183f2b71675f84ff3b896d9692b9f7b53fc978

Additional info:
* 1.3.6-9

Steps to reproduce:
asp export extra/slim
cd slim
staging-x86_64-build
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 19 December 2021, 04:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  slim 1.3.6-10
Comment by Andreas Baumann (andreas_baumann) - Monday, 29 November 2021, 14:23 GMT Comment by loqs (loqs) - Tuesday, 30 November 2021, 00:13 GMT
Looking at [1] XCreateGC can return NULL which is what the test may have been intended to check for?
Edit:
Fedora seem to have come to the same conclusion [2].

[1] https://gitlab.freedesktop.org/xorg/lib/libx11/-/blob/master/src/CrGC.c#L64
[2] https://src.fedoraproject.org/rpms/slim/blob/rawhide/f/slim-gcc11.patch

Loading...