Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72851 - [vim] Upstream source has changed

Attached to Project: Arch Linux
Opened by Jonathon (jonathon) - Saturday, 27 November 2021, 00:16 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 27 November 2021, 08:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The Vim GitHub repo has removed all releases but retained tags. Attached git diff updates the source URL.

Additional info:
n/a

Steps to reproduce:
* Grab PKGBUILD
* makepkg
* ERROR: Failure while downloading https://github.com/vim/vim/archive/refs/tags/vim-8.2.3682.tar.gz
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 27 November 2021, 08:02 GMT
Reason for closing:  Not a bug
Additional comments about closing:  GitHub issue
Comment by Jonathon (jonathon) - Saturday, 27 November 2021, 00:17 GMT
That's the wrong URL in the error... can't edit it now though, and the result is the same.
Comment by Antonio Rojas (arojas) - Saturday, 27 November 2021, 08:01 GMT
every single GitHub url is broken ATM, see https://github.com/github/feedback/discussions/8149

Loading...