Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72838 - [gnome-builder] Crash on startup due to depend on two versions of two set of libraries

Attached to Project: Arch Linux
Opened by shenlebantongying (shenlebantongying) - Thursday, 25 November 2021, 10:46 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 25 November 2021, 11:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The current version cannot be opened and always pop this message
```
(process:67379): libsoup-ERROR **: 05:30:24.019: libsoup2 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported.
fish: Job 1, 'gnome-builder' terminated by signal SIGTRAP (Trace or breakpoint trap)
```

Additional info:

By biseting the result of `pactree gnome-builder`, here is what I find:

Gnome-builder <- devhelp <- *webkit2gtk-4.1* <- libsoup3
Gnome-builder <- gtk3 <- rest <- libsoup3

Gnome-builder <- *webkit2gtk* <- libsoup
Gnome-builder <- gtk3 <- tracker3 <-libsoup

Right now, GTK3 depends on two versions of libsoup, and gnome-builder depends on two versions of webkit2gtk.

The hidden indirect dependency may be the cause of crash.



This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 25 November 2021, 11:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#72837 

Loading...