Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72837 - [gnome-builder] libsoup and libsoup3 updates breaks the app

Attached to Project: Arch Linux
Opened by Veli (tasali) - Thursday, 25 November 2021, 10:38 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 25 November 2021, 14:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
libsoup 2.74.2-1 and libsoup3 3.0.3-1 updates break gnome-builder 41.2-2. Downgrading libsoup to 2.74.1-1 and libsoup3 to 3.0.2-1 fixes the problem.

The error that is thrown is:

(process:39353): libsoup-ERROR **: 13:33:03.320: libsoup2 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported.
Trace/breakpoint trap (core dumped)

Rebuilding gnome-builder with the updates on a clean chroot also results in the same error during the generation of gir files.

Additional info:
* package version(s)
extra/gnome-builder 41.2-2 (gnome-extra)
extra/libsoup 2.74.2-1
extra/libsoup3 3.0.3-1

Steps to reproduce:
1. Update the packages
2. Try to run gnome-builder
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 25 November 2021, 14:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  devhelp 41.2-3

Loading...