Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72836 - [chromium] [clang] Cannot build chromium on AMD 5950X

Attached to Project: Arch Linux
Opened by John (graysky) - Thursday, 25 November 2021, 10:08 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 09 December 2021, 04:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am unable to build chromium on an AMD 5950X based machine whereas it builds successfully on other Intel machines. I do not know if this is something unique to clang or chromium. I cannot trigger a similar failure building other projects such as kodi or the linux kernel using clang on this hardware. It seems unique to chromium.

I attached the build log as well as a tar.gz containing the two referenced files from clang:
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
clang++: note: diagnostic msg: ../../tools/clang/crashreports/dom_window-b22f66.cpp
clang++: note: diagnostic msg: ../../tools/clang/crashreports/dom_window-b22f66.sh
clang++: note: diagnostic msg:

********************

* clang 13.0.0-2
* chromium 96.0.4664.45-2

Steps to reproduce:

1. Attempt to build chromium in a clean chroot using makechrootpkg
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 09 December 2021, 04:51 GMT
Reason for closing:  Won't fix
Additional comments about closing:  2021-12-06: A task closure has been requested. Reason for request: My workstation turns out has a bad DIMM. Removing it allowed me to build. This is NOT a bug, just bad hardware. Plz close.
Comment by John (graysky) - Thursday, 25 November 2021, 10:10 GMT
The crashreport files exceed the 2.0 MiB limit even compressed with zstd --ultra -20

Loading...