Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72830 - [manuskript] Package crashes when adding a second *detailed info field* to *Characters pane*

Attached to Project: Community Packages
Opened by (IrvineHimself) (IrvineHimself) - Wednesday, 24 November 2021, 16:00 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 05 December 2021, 08:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Using either the Official build or the *git* build from the AUR, the package crashes when adding a new *detailed info field* in the *Characters pane*

On the other hand, after downloading the *zip* file, running *<ZipPkgDir>/bin/manuskript*

works without problem

Package versions:

Manuskript 0.12.0
Python 3.9.7
PyQt 5.15.6
Qt 5.15.2

Links to upstream bug reports:

Official build traceback: https://github.com/olivierkes/manuskript/issues/945#issuecomment-977462467

AUR git traceback: https://github.com/olivierkes/manuskript/issues/945#issuecomment-977959711

Steps to reproduce:

1) Install either *manuskript* or *manuskript-git*
2) Create new character
3) Add a *detailed info field*
3) Crashes when a second *detailed info field* is added

4) Download the zip file
5) Unzip to wherever you run executables
6) Run <PkgDir>/bin/manuskript
7) Create new character
8) Add a *detailed info field*
9) A second *detailed info field* can be added without problems

Irvine
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 05 December 2021, 08:50 GMT
Reason for closing:  None
Additional comments about closing:  Because the Git and Official builds were having the same problem while the Zip pkg was unaffected, it looked as if the source of the problem was Arch. It seems that upstream maintains two branches, *main* and *development*. The *main-branch* is identical to the latest binaries, ie: it is only updated with each release. To get the true *git-package*, the Aur PKGBUILD should be pulling from the *development-branch*. see https://github.com/olivierkes/manuskript /issues/945#issuecomment-977996095 Since the bug report was filed under a false predicate and the issue will be fixed in version 0.13.0 you might as well close this Irvine
Comment by (IrvineHimself) (IrvineHimself) - Wednesday, 24 November 2021, 16:51 GMT
Because the Git and Official builds were having the same problem while the Zip pkg was unaffected, it looked as if the source of the problem was Arch.

It seems that upstream maintains two branches, *main* and *development*. The *main-branch* is identical to the latest binaries, ie: it is only updated with each release.

To get the true *git-package*, the Aur PKGBUILD should be pulling from the *development-branch*.

see
https://github.com/olivierkes/manuskript/issues/945#issuecomment-977996095

Since the bug report was filed under a false predicate and the issue will be fixed in version 0.13.0 you might as well close this

Irvine


Loading...