Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#727 - gtk2 broken after last upgrade

Attached to Project: Arch Linux
Opened by Jan de Groot (JGC) - Sunday, 11 April 2004, 09:13 GMT
Last edited by arjan timmerman (blaasvis) - Sunday, 11 April 2004, 09:49 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To dorphell (dorphell)
Architecture not specified
Severity Critical
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

The recent GTK "fix" might have fixed that one theme, but it broke ALL gnome themes.

This is the same problem we have with testing packages. I advised to use a patch I had in my builds for months, but instead of that you decided to use the --datadir=/opt/gnome/share way.

Now you're removing the thing again. If it's supposed to be removed, please reconsider the patch.

http://schoolbak.dyndns.org/arch-bugs/patch-gtk_gtkicontheme.c
This task depends upon

Closed by  dorphell (dorphell)
Monday, 12 April 2004, 07:02 GMT
Reason for closing:  Fixed
Comment by arjan timmerman (blaasvis) - Sunday, 11 April 2004, 11:58 GMT
# $Id: PKGBUILD,v 1.24 2004/04/05 18:24:54 dorphell Exp $
# Maintainer: dorphell <dorphell@archlinux.org>
pkgname=gtk2
pkgver=2.4.0
pkgrel=1
pkgdesc="The GTK+ Toolkit (v2)"
install=gtk2.install
depends=('atk' 'pango' 'libpng' 'libtiff' 'libjpeg')
source=(ftp://ftp.gnome.org/pub/gnome/sources/$pkgname/2.4/gtk+-$pkgver.tar.bz2)url="http://www.gtk.org/"
md5sums=('fd16157de447c7f0a86495ad0dc67a1b')

build() {
cd $startdir/src/gtk+-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--datadir=/opt/gnome/share --with-xinput=yes
make || return 1
make DESTDIR=$startdir/pkg install
mkdir -p $startdir/pkg/usr/share/themes/{Default,Emacs}/gtk-2.0-key
mv $startdir/pkg/opt/gnome/share/themes/Default/gtk-2.0-key/* $startdir/pkg/usr/share/themes/Default/gtk-2.0-key
mv $startdir/pkg/opt/gnome/share/themes/Emacs/gtk-2.0-key/* $startdir/pkg/usr/share/themes/Emacs/gtk-2.0-key
}

^^ other solution
Comment by dorphell (dorphell) - Sunday, 11 April 2004, 16:12 GMT
Blaavis has found the bug with the default keys to be a control-center problem, so it wasn't gtk2's fault to begin with. I did remove that datadir by mistake, I just forgot we stored themes there, I don't use themes and forgot.

JGC: As for your patch... you've not told me for months, it was a few conversations in a period of maybe 1 week, and I've told you several times it does the same as --datadir=/opt/gnome/share and not even as cleanly, so don't be bitter at me, that patch is *not* better, and there's no need to add redundant patches.


I'll add datadir back in a little while. (after Blaavis fixes his control-center bug)
Comment by Jan de Groot (JGC) - Sunday, 11 April 2004, 16:42 GMT
hehe, I didn't tell you for months, but the patch was there since libgnomeui changed GnomeIconTheme to a wrapper around GtkIconTheme, from that point I started using the patch, and that one has been in my repository for months ;)

You only knew about it one or two days before releasing gtk 2.4.0 in archlinux. Sorry about the misunderstanding.
Comment by dorphell (dorphell) - Sunday, 11 April 2004, 23:05 GMT
Well, after looking at this several times today, Blaavis nor I have pin-pointed the bug yet, mainly because I don't have gnome installed and Blaavis is out of ideas. I'm pretty sure though that it's a gnome bug.

The problem is that when we define --datadir, it uses it locally in the gtk2 install but this is not populated correctly to other gnome components at runtime, thus they still look in /usr.

JGC's patch does not solve this

We can do something like JGC's patch but our initial goal is to restrict gnome shared files to /opt/gnome and thus, JGC's patch is only a last resort, which is why I've dodged it thus far, JGC.

Furthermore, to show that that your patch is not a solution, try adding the --datadir to your PKGBUILD. The 'key' problem should appear as the default keys get placed in /opt/gnome without informing other pkgs.

Blaavis: we've tried to add --datadir to control-center but is that what reads the key binding in gnome? Try adding it to other parts of gnome that may look for bindings. If you still can't find any, I'll go without --datadir =(

If I can't find a direct solution in the next 12-24 hours, I will get rid of --datadir and add something like your patch.
Comment by dorphell (dorphell) - Monday, 12 April 2004, 07:02 GMT
okay we've decided that /usr/share is fine for gtk2 themes, no need for the /opt/gnome stuff at all (but i left it in just in case)

Loading...