Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72799 - [xorg-server] 21.1.1-2 update causes random crashes

Attached to Project: Arch Linux
Opened by zjeffer (zjeffer) - Saturday, 20 November 2021, 19:40 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 21 November 2021, 09:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Andreas Radke (AndyRTR)
Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Description:


Since the last couple of days, Xorg crashes about once a day, completely at random. When it crashes, my monitors turn black and a couple seconds afterwards LightDM's login manager pops up.

Strangely, two of the crashes happened when watching videos on reddit, both when something very loud and high-pitched suddenly happened. The crash happens either right when the loud noise happens, or right when I quickly lower my volume using my mouse buttons. I'm always using headphones, connected to the 3.5mm port (Beyerdynamic DT 770 Pro 80 Ohm).
Other crashes seem to be random. I haven't had any crashes happen when the monitors weren't plugged in, but I haven't used my laptop that way much lately.

Looking at `journalctl`, the crash always happen right after these ACPI jack/videoout and jack/lineout lines:

Nov 20 11:16:00 zjeffer root[251860]: ACPI group/action undefined: jack/lineout / LINEOUT
Nov 20 11:16:00 zjeffer root[251862]: ACPI group/action undefined: jack/videoout / VIDEOOUT

Full output of `journalctl -b` attached. You can see the full backtrace there, just match up the timestamps from the above 2 lines.

These ACPI videoout and lineout lines seem to pop up quite often, but they don't always cause a crash. I don't think I've ever seen them before until this week, and I've had this laptop since July.

Additional info:
* Arch 5.15.2, using bspwm, Nvidia proprietary driver version 495.44-9.
* xorg-server version 21.1.1-3
* My system is a Lenovo Legion 5 Pro with Ryzen 7 5800H, RTX 3070 Mobile and 16GB RAM.
* I'm using two external monitors: one connected to HDMI, one to a USB-C output.
This task depends upon

Comment by zjeffer (zjeffer) - Sunday, 21 November 2021, 10:24 GMT
Here's a thread with some more info, including some others who have the same problem: https://bbs.archlinux.org/viewtopic.php?id=271450

Interestingly, only I seem to get the ACPI lines when the crash happens.
Comment by zjeffer (zjeffer) - Sunday, 28 November 2021, 10:43 GMT
It crashed again, here are the journalctl logs from that day and the xorg log from that session.

Loading...