Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72767 - dotnet-sdk, dotnet-runtime, dotnet-targeting-pack don't install

Attached to Project: Community Packages
Opened by Dieter Lunn (coder2000) - Tuesday, 16 November 2021, 18:55 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 16 November 2021, 19:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Trying to update my system and the dotnet packages are experiencing conflicts which stop all other updates. Please find a trace of the issue below.

Additional info:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (22) aspnet-runtime-6.0.0.sdk100-2 cheese-41.1-1 dkms-3.0.1-1 dotnet-runtime-6.0.0.sdk100-2 dotnet-sdk-6.0.0.sdk100-2
dotnet-targeting-pack-6.0.0.sdk100-2 git-2.34.0-1 glslang-11.7.0-1 imagemagick-7.1.0.14-1 json-c-0.15-2 libcheese-41.1-1
libunrar-1:6.1.2-1 netstandard-targeting-pack-6.0.0.sdk100-2 openal-1.21.1-2 pcre2-10.39-1 python-markdown-3.3.5-1 python-rich-10.14.0-1
qt5-base-5.15.2+kde+r256-1 qt5-declarative-5.15.2+kde+r40-1 sleuthkit-4.11.1-1 telegram-desktop-3.2.5-1 thunderbird-91.3.1-1

Total Installed Size: 854.09 MiB
Net Upgrade Size: 0.30 MiB

:: Proceed with installation? [Y/n]
(22/22) checking keys in keyring [########################################################] 100%
(22/22) checking package integrity [########################################################] 100%
(22/22) loading package files [########################################################] 100%
(22/22) checking for file conflicts [########################################################] 100%
error: failed to commit transaction (conflicting files)
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.android/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.android/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.ios/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.ios/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.maccatalyst/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.maccatalyst/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.macos/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.macos/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.maui/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.maui/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.tvos/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.sdk.tvos/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.workload.emscripten/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.workload.emscripten/WorkloadManifest.targets exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.workload.mono.toolchain/WorkloadManifest.json exists in filesystem
dotnet-sdk: /usr/share/dotnet/sdk-manifests/6.0.100/microsoft.net.workload.mono.toolchain/WorkloadManifest.targets exists in filesystem
Errors occurred, no packages were upgraded.
-> error installing repo packages


Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 16 November 2021, 19:11 GMT
Reason for closing:  Not a bug
Additional comments about closing:  https://wiki.archlinux.org/title/pacman# %22Failed_to_commit_transaction_(conflic ting_files)%22_error

Loading...