Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72759 - Xorg-server crash after updating xorg-server and xf86-video-ati

Attached to Project: Arch Linux
Opened by Sébastien Bernard (sbskas) - Monday, 15 November 2021, 12:14 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 18 November 2021, 13:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
update to latest package cause xorg-server to crash.
Updating packages:
xorg-server
xorg-server-common
xorg-server-xvfb
from 1.20.13-2 to 21.1.1-3
and
xf86-video-ati from 19.1.0-2 to 19.1.0.r9.g5eba0006e-1

Steps to reproduce:
Update the package, restart the xorg server, watch it crash.
Reverting to previous pacakges fix the crash.

It's not possible to tell which system causes the crash between xorg-server and the xf86 ati driver since packages are mutually depends.

Full Xorg log file is included.
Here's an extract of the log:
323.839] (EE) RADEON(0): drmmode_do_crtc_dpms cannot get last vblank counter
[ 323.864] (II) RADEON(0): Allocate new frame buffer 2400x1920
[ 323.866] (II) RADEON(0): VRAM usage limit set to 208206K
[ 323.867] (EE)
[ 323.867] (EE) Backtrace:
[ 323.867] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x5b) [0x560a2e07bddb]
[ 323.867] (EE) 1: /usr/lib/Xorg (0x560a2df30000+0x156a15) [0x560a2e086a15]
[ 323.867] (EE) 2: /usr/lib/libpthread.so.0 (0x7fd22680c000+0x13870) [0x7fd22681f870]
[ 323.867] (EE)
[ 323.867] (EE) Segmentation fault at address 0x0
[ 323.867] (EE)
Fatal server error:
[ 323.867] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 323.867] (EE)
[ 323.867] (EE)

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 18 November 2021, 13:16 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Monday, 15 November 2021, 19:35 GMT
Test the vesa driver to sort out the ati driver updates.
Feel free to rebuild the new ati driver against the old xserver and downgrade to confirm this.

Please also check for known upstream bugs:
https://gitlab.freedesktop.org/xorg/xserver/-/issues
https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/-/issues
Comment by Sébastien Bernard (sbskas) - Tuesday, 16 November 2021, 10:55 GMT
It seems the bug has been reported back here:
https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/-/issues/198
with a PR pending:
https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/-/merge_requests/9

I confirm the driver no longer crash witch this patch. It seems to fix problems with xrandr also.
Comment by Sébastien Bernard (sbskas) - Tuesday, 16 November 2021, 11:55 GMT
Please find a patch for the package to include the fix.
Comment by Sébastien Bernard (sbskas) - Tuesday, 16 November 2021, 11:58 GMT
Also the patch file referenced in the PKGBUILD.
   9.diff (0.8 KiB)
Comment by Andreas Radke (AndyRTR) - Tuesday, 16 November 2021, 19:24 GMT
Please confirm xf86-video-ati-1:19.1.0.r9.g5eba006e-2 in testing repo working for you.
Comment by Sébastien Bernard (sbskas) - Thursday, 18 November 2021, 08:50 GMT
I confirm the package in testing fixes the crash.

Loading...