Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#72743 - [mediathekview] ttf-dejavu is a missing dependency

Attached to Project: Community Packages
Opened by Peter Mueller (hcrab) - Sunday, 14 November 2021, 09:02 GMT
Last edited by David Runge (dvzrv) - Saturday, 20 November 2021, 14:13 GMT
Task Type Bug Report
Category Packages
Status Researching
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Without the font ttf-dejavu MediathekView shows some dialog boxes without text
but it is usable. I'm not sure Java would use some other fonts here as well but
maybe ttf-dejavu could be an optional dependency.

Additional info:
* package version: 13.8.0-2

Steps to reproduce:
Install MediathekView on a system without desktop environment or other Java
applications installed.
This task depends upon

Comment by David Runge (dvzrv) - Saturday, 20 November 2021, 14:13 GMT
@hcrab: Thanks for the report.

It seems to be a fallback font. In the codebase FontAwesome is mentioned which I guess is available via ttf-font-awesome.
Would you be able to try with that package installed (instead of ttf-dejavu) and report back?
Comment by Peter Mueller (hcrab) - Saturday, 20 November 2021, 17:11 GMT
@dvzrv: Thanks for the package!

I tried ttf-font-awesome but it didn't work.
Comment by David Runge (dvzrv) - Sunday, 20 February 2022, 12:32 GMT
@hcrab: Did you follow to configure the fonts for your Java environment?

If so, what did work, what didn't work?
Comment by Peter Mueller (hcrab) - Thursday, 24 February 2022, 15:17 GMT
@dvzrv: I tried most of the stuff at the early beginning of investigating this issue and e.g. anti-aliasing worked as expected. I never change the font path because after installing ttf-dejavu the issue was gone and I assumed that the path is recognized by the JRE.