Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#72725 - GRUB not timing out or recognizing internal keyboard (only on reboot & only in Arch)

Attached to Project: Arch Linux
Opened by Aniket (aniket) - Friday, 12 November 2021, 14:18 GMT
Last edited by Jonas Witschel (diabonas) - Wednesday, 17 November 2021, 21:12 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Christian Hesse (eworm)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


## Problem
GRUB doesn't automatically timeout or recognize laptop's keyboard on reboot but works just fine on a normal boot (with a shutdown). When stuck on reboot, I need to manually poweroff my laptop with the power button. The peculiar thing is that even though GRUB never times out on reboot, it intermittently recognizes external wireless keyboard and not the laptop's internal one.

The problem started occurring around October (unfortunately can't pinpoint the date) but never before.

Any help is highly appreciated!!

## Why file bug with Arch?
The problem doesn't occur on Fedora (same GRUB version) or Debian (installed each individually)

## Current Setup
- Lenovo Ideapad Z580 (I5 3rd Gen, 8GB/SSD, UEFI)
- Trying newer ISO for installation
- Previously used `10-2021` ISO
- Now used `11-2021` ISO
- GRUB Version 2.06
- `SecureBoot` and `FastBoot` are disabled
- `GRUB_TIMEOUT` is set to `10`

## Steps Tried
- Regenerating `grub.cfg`
- Installing LTS kernel
- Disconnecting all USB peripherals
- Setting `RebootWatchdogSec=0` in `/etc/systemd/system.conf`
- Used to get `watchdog didn't stop` message on reboot. Referred
- Reverted the change
- `journalctl -b 1` (systemd) logs don't seem to show any errorrelated to this
- Reinstalling GRUB
- Uninstalled `grub` package
- Deleted `/boot/grub/` directory
- Deleted grub's dir. in ESP
- Reinstalled `grub` package
- Ran `grub-install` and `grub-mkconfig`
- Downgrading GRUB
- Installed `GRUB 2.04-6` from Arch Linux Archive
- Problem still persisted (reboot only)

## Observation
- The problem occurs even if no DE is installed
- Tried on a clean install
This task depends upon

Closed by  Jonas Witschel (diabonas)
Wednesday, 17 November 2021, 21:12 GMT
Reason for closing:  Upstream