Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72702 - Latest Xorg update broke my X

Attached to Project: Arch Linux
Opened by Lucas Rizzini (lucasrizzini) - Wednesday, 10 November 2021, 21:01 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Tuesday, 16 November 2021, 06:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After updating, Xorg can't detect any screens with my NVIDIA 340.XXX drivers/9800GT card. I tried to downgrade to 1.20.13-3, which makes my X load, but with unresponsive keyboard and mouse.

Xorg.0.log(Attached):
[ 795.772] ================ WARNING WARNING WARNING WARNING ================
[ 795.772] This server has a video driver ABI version of 25.2 that this
driver does not officially support. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[ 795.772] =================================================================

Additional info:
* xorg-server-21.1.1-2, xorg-server-devel-21.1.1-2 and xorg-server-common-21.1.1-2
* Probably related to this bug: https://www.reddit.com/r/archlinux/comments/qr1d00/the_latest_xorgserver_wont_start_had_to_downgrade/
* Specs: Kernel 5.14.17-216-tkg-pds / NVIDIA 340.108-24 drivers / 9800GT card

Steps to reproduce:
FailUpdate to latest updates and restart
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Tuesday, 16 November 2021, 06:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not really a bug since NVIDIA have ceased support for this Xorg version and I don't think there's anything we can do here.
Comment by Lucas Rizzini (lucasrizzini) - Wednesday, 10 November 2021, 21:15 GMT
Adding IgnoreABI to my /etc/X11/xorg.conf indeed work around the issue. Now I'm able to boot my updated to 21.1.1-2 Xorg.

Section "ServerFlags"
Option "IgnoreABI" "true"
EndSection
Comment by loqs (loqs) - Wednesday, 10 November 2021, 21:17 GMT
What if you add the following to the ServerFlags section of xorg.conf?

Option "IgnoreABI" "True"

If that does not work you may need to stay on the older Xorg server version as nvidia has ceased supporting 340x [1]

[1] https://nvidia.custhelp.com/app/answers/detail/a_id/3142
Comment by Lucas Rizzini (lucasrizzini) - Wednesday, 10 November 2021, 21:21 GMT
Coincidentally, I was writing that this worked while you were writing your comment.

Thanks for the link. How is gonna be from now on? Just not update xorg-server, xorg-server-devel and xorg-server-common packages?
Comment by loqs (loqs) - Wednesday, 10 November 2021, 21:28 GMT
If there are any future Xorg releases which is not certain. Should those Xorg release be incompatible with 340x and the using IgnoreABI produces crashes you could as a short term work around not update the packages.
In the long term that would lead to incompatibility with other updates and you would either have to stop updating the system or locally build the old release of the xorg packages against newer dependencies.
Edit:
Other option I neglected to mention would be to switch fron nvidia to nouveau.
Comment by Alex Rouse (the_Guardian) - Friday, 12 November 2021, 03:27 GMT
Try installing an earlier version.
Comment by Lucas Rizzini (lucasrizzini) - Friday, 12 November 2021, 09:17 GMT
This is a bug report, Alex.
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 16 November 2021, 06:20 GMT
This is a really old driver. I only currently package the most recent driver. At any rate, is this a driver problem or an Xorg upstream problem? We can't really support this currently I think if NVIDIA themselves have ceased support.

Loading...