Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72678 - [linux] 5.15.1: Laptop (ASUS VivoBook S530U) fails to complete boot process

Attached to Project: Arch Linux
Opened by João O. Santos (Joao-O-Santos) - Tuesday, 09 November 2021, 14:36 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 15 November 2021, 20:29 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: After upgrading to 5.15.0 and, more recently, to 5.15.1 laptop no longer completes boot process.

When I upgraded the system (pacman -Syu) last week my laptop no longer booted.
By no longer booting I mean that it reaches the boot loader, probably loads the initramfs, but the messages appear all jarred on the screen and it stalls.

What I've done to fix it:
- Using the installation media and reverting the linux package to an earlier version (5.14 was working) seems to be the only, necessary and sufficient, fix for the problem.
- Compiling the 5.15.0 kernel from kernel.org, using the traditional compilation with localmodconfig, yields a bootable kernel (using the [linux-lts] package also works).

Were there any changes to the Arch Linux kernel config that could cause it to no longer work in my system?
Please let me know what steps I can take to better diagnose this problem.

I don't have much experience writing bug reports so I apologize if this one is not up to par.

Thank you for your work on Arch,
João

Additional info:
* package version(s) - tested on both 5.15.0, and 5.15.1
* config and/or log files etc. - Standard Arch Linux kernel build (see above).
* My boot manager (UEFI) is systemd-boot, it is up-to-date and working with other kernels.
* My laptop is an ASUS VivoBook S530U and everything was working fine until 5.14.0.

Steps to reproduce:
Booting using the [linux] package from [testing] (versions 5.15.0, and 5.15.1) on an ASUS VivoBook S530U laptop.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 15 November 2021, 20:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#72645 
Comment by loqs (loqs) - Tuesday, 09 November 2021, 16:52 GMT
 FS#72645  ?
Comment by João O. Santos (Joao-O-Santos) - Wednesday, 10 November 2021, 09:36 GMT
@loqs I can confirm the linked solution works (though I had to also unset CONFIG_IKHEADERS as my machine has headers).

As stated in the linked thread, and as I've confirmed, this problem persists in [linux] 5.15.1.arch1-2

Moreover, I'm not sure if my problem isn't more severe. Some people in that thread reported having a black screen, and being able to login to the tty blind.
However my screen isn't black, the boot process information remains there all jarred (instead of left-aligned and readable as usual).
Still, feel free to close this issue if you consider it a duplicate.

@huyizheng reported that simply changing CONFIG_SYSFB_SIMPLEFB to module could fix the problem (I'll test if that works for me and check back).

Is this a setting the Arch Linux team is willing to change in the official configuration?

Please let me know if there's anything more I can do.
Comment by Lubos Kolouch (kolcon) - Wednesday, 10 November 2021, 20:09 GMT
It gets stuck much earlier (I have a garbled output too, with Intel integrated graphics).

I'm not even able to decrypt the disk early in the boot, it does not accept any keyboard input... (or at least it is doing nothing)
Comment by Marius (Martchus) - Wednesday, 10 November 2021, 20:27 GMT Comment by Lime (LimeInkling) - Saturday, 13 November 2021, 16:10 GMT
Just popping in to let you all know that I am experiencing a similar regression on my HP EliteBook 8540p with an NVIDIA NVS 5100M, even on the latest kernel version (5.15.2-arch1-1). systemd completes its whole boot process, but I just get a black screen at the xorg stage. I am using nouveau drivers.

Interestingly enough, systemd gives me the following message during boot-up, which I don't remember being there before:
[ FAILED ] Failed to start Load/Save Screen Backlight Brightness of backlight:nv_backlight
Not sure if this has anything to do with anything, but I'll mention it nonetheless.
Comment by João O. Santos (Joao-O-Santos) - Monday, 15 November 2021, 20:19 GMT
UPDATE: I just want to let everyone know, that this is issue has been fixed with the latest [linux] package update.
I have not checked if it persists with [linux-zen] but I'd bet both kernels' config have been updated.

@heftig, thank you very much for being on top of this issue.

Loading...