Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72662 - [atool] PLEASE ENTER SUMMARY

Attached to Project: Community Packages
Opened by Andrey (am0z) - Monday, 08 November 2021, 08:49 GMT
Last edited by Jaroslav Lichtblau (Dragonlord) - Saturday, 05 February 2022, 18:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
atool uses hardcoded permission when creating new directories. This introduces problems for use-cases of multiple users on a system trying to handle files on shared volumes.


Additional info:
* package version(s)
0.39.0-7
* link to upstream bug report, if any
Upstream is basically dead so here's a fork with the issue fixed. https://github.com/z3ntu/atool/issues/1

Steps to reproduce:
* have a shared volume with setfact configured to force all new files be accessible to a `group`
* user_a and user_b belong to the same `group`
* user_a aunpacks an archive into shared volume creating new directory
* user_b can't do anything with that directory because atool applies hard-coded permission (700) to new directories

Proposed solutions:
( since upstream author email address bounces )
* switch to a maintained fork
* or create new fork to maintain
This task depends upon

Closed by  Jaroslav Lichtblau (Dragonlord)
Saturday, 05 February 2022, 18:17 GMT
Reason for closing:  Won't fix
Comment by Jaroslav Lichtblau (Dragonlord) - Saturday, 05 February 2022, 18:17 GMT
atool dropped to AUR

Loading...