Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72648 - gc package miss the gc_pthread_redirects.h

Attached to Project: Arch Linux
Opened by shenlebantongying (shenlebantongying) - Saturday, 06 November 2021, 07:54 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 06 November 2021, 17:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The current gc package miss the file `gc_pthread_redirects.h`

I was trying to rebuild guile3 from AUR but failed due to missing `gc_pthread_redirects.h`, and it turn out to be the gc package miss it.

https://archlinux.org/packages/extra/x86_64/gc/

Additional info:

I used to build guile3 successfully, I guess the some recent change (in upstream?) accidentally drops the file or the build script need a new flag?

Other distros contain this file,

https://packages.debian.org/sid/amd64/libgc-dev/filelist

Steps to reproduce:

install gc package, and there are no `gc_pthread_redirects.h`
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 06 November 2021, 17:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  gc 8.2.0-2
Comment by shenlebantongying (shenlebantongying) - Saturday, 06 November 2021, 08:22 GMT
Manually copy `gc_pthread_redirects.h` into /usr/include/gc/ fixes the guile3 build problem for me.
Comment by Antonio Rojas (arojas) - Saturday, 06 November 2021, 10:10 GMT
Looks like https://github.com/ivmai/bdwgc/commit/06e4efff9949a670d41e4455ca1d4eee3d9ba58c is not working as intended, as we are certainly using pthreads

Loading...