FS#72638 - [hledger] Error message for every command executed

Attached to Project: Community Packages
Opened by samyak (samyak) - Thursday, 04 November 2021, 23:10 GMT
Last edited by Caleb Maclennan (alerque) - Wednesday, 24 November 2021, 19:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Caleb Maclennan (alerque)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


Every time I execute an hledger command, I get this output
hledger: /usr/lib/libncursesw.so.6: no version information available (required by /usr/lib/libHShledger-1.22.2-14Z1MxICp3P2wuTw81TFyY-ghc9.0.1.so)
This program seems to be working but it is a bit annoying to have this prepended to every output from the command

Additional info:
* package version(s): hledger 1.22.2-32
* config and/or log files etc.: NA
* link to upstream bug report, if any: NA. Reporting this here because when building from source, I can confirm that I am not facing this issue. Have this issue only when installing though pacman.

Steps to reproduce:
Just install the package: ```package -S hledger``` and run ```hledger --version```
This task depends upon

Closed by  Caleb Maclennan (alerque)
Wednesday, 24 November 2021, 19:40 GMT
Reason for closing:  Works for me
Additional comments about closing:  Neither I nor the original poster can replicate any more.
Comment by Caleb Maclennan (alerque) - Wednesday, 24 November 2021, 02:39 GMT
I am unable to replicate this. In fact I use `hledger` on a regular basis and haven't ever seen this, and just tried and can't replicate it right now either. I suspect your system is out of sync and you are in some unsupported partial upgrade state. I'm guessing you have a new hledger version but paired with old system libraries. Have you done a full system update with `pacman -Syu`?
Comment by samyak (samyak) - Wednesday, 24 November 2021, 07:01 GMT
Weird. It works now. I am pretty sure everything was updated when I reported this. Anyway, since this issue seems to have been resolved, it can be closed. Thanks!