Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72632 - kernel linux-zen 5.15.zen1-1 invisible cursor startx does not work

Attached to Project: Arch Linux
Opened by John Barks (Zod) - Thursday, 04 November 2021, 16:21 GMT
Last edited by Jonas Witschel (diabonas) - Wednesday, 10 November 2021, 18:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:kernel linux-zen 5.15.zen1-1 invisible cursor and X won't start


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

fresh install with testing and community testing enabled
install xorg and xorg-xinit
install kde system, utilities, network and grapjics meta packages

Using xinit and startx, xorg does not start.
Using DM sddm, x starts but the mouse pointer is invisible.

I re-installed xorg and kde-meta packages which didn't fix.
Down-grading the kernel to 5.14.16-zen1-1-zen resolved the issue

sudo journalctl -b 11 --no-pager

http://ix.io/3E0B
   journal (217 KiB)
This task depends upon

Closed by  Jonas Witschel (diabonas)
Wednesday, 10 November 2021, 18:14 GMT
Reason for closing:  Works for me
Additional comments about closing:  Cannot reproduce
Comment by John Barks (Zod) - Thursday, 04 November 2021, 16:25 GMT
Also re-installing plasma didn't help.
Comment by John Barks (Zod) - Saturday, 06 November 2021, 18:07 GMT
Just upgraded to 5.15 and cannot reproduce.
I'll request closing this.

Loading...