Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72608 - [remmina] missing plugins

Attached to Project: Community Packages
Opened by zeroconf (zeroconf) - Monday, 01 November 2021, 22:58 GMT
Last edited by Jonas Witschel (diabonas) - Monday, 01 November 2021, 23:12 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Remmina has missing plugins, especially some important ones: RDP, VNC.

Additional info:
* package version(s): 1.4.21-1 (https://archlinux.org/packages/community/x86_64/remmina/)
* config and/or log files etc.: N/A
* link to upstream bug report, if any: N/A

Steps to reproduce:
1. install Remmina from community repository
2. open program Plugins menu
3. RDP, VNC are missing, only SSH is bundled

Certainly it would be very much appreciated to have all other plugins bundled as well. But e.g. VNC plugin was awful - there was wine installed as dependency with MS Windows version of UltraVNC... As far as I remember from Debian, Ubuntu world, there were plugins available and VNC was native Remmina plugin. Would expect plugins work natively inside Remmina and not with help of external program.

Currently only via AUR there are plugins available. Would expect to have plugins together from same repository as main program. It is pretty obvious, that plugins are small addons, that could be easily bundled with main program in order to ensure these would be available, whenever needed. That need appears often suddenly. Could be also separate packages, but at least compatible with main program and available in same repository, kept same version as main program or at least latest version available.
This task depends upon

Closed by  Jonas Witschel (diabonas)
Monday, 01 November 2021, 23:12 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Remmina plugins like RDP, VNC or NX require installation of the listed optional dependencies in order to work
Comment by zeroconf (zeroconf) - Monday, 01 November 2021, 23:01 GMT
That was nice to see, that support for local credential manager plugins, like KWallet, glibsecret were bundled initially.
Comment by zeroconf (zeroconf) - Monday, 01 November 2021, 23:09 GMT
Although VNC plugin has only 256 colors (8 bpp)

Loading...