Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72596 - Pacman: alien file help-dummy.o found in /var/cache/pacman/pkg/ directory

Attached to Project: Arch Linux
Opened by Jamp (jamp) - Sunday, 31 October 2021, 19:32 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 02 November 2021, 18:07 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Hi, i executed the command pacman -Sc

and got this error message

Packages to keep:
All locally installed packages

Cache directory: /var/cache/pacman/pkg/
:: Do you want to remove all other packages from cache? [Y/n]
removing old packages from cache...
error: could not open file /var/cache/pacman/pkg/help-dummy.o: Unrecognized archive format

Since I am normally careful to not operate as root when it is not needed I am wondering about the origin of that file.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 02 November 2021, 18:07 GMT
Reason for closing:  Not a bug
Comment by John (graysky) - Sunday, 31 October 2021, 20:17 GMT
If I am not mistaken, help-dummy.o can be generated by running `gcc -c -Q -march=x86-64 --help=target` and other switches. Guessing you did this in the cache dir. This file is not supplied by any package to my knowledge.

% pkgfile help-dummy.o
% echo $?
1
Comment by Jamp (jamp) - Sunday, 31 October 2021, 21:02 GMT
Probably you are right.. I don't remember that command but this file it is the unexpected (by me) outcome of that command.
Thank you
Comment by Jamp (jamp) - Monday, 01 November 2021, 07:40 GMT
Probably you are right.. I don't remember that command but this file it is the unexpected (by me) outcome of that command.
Thank you

Loading...