Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72580 - [chromium] [ffmpeg] unresolved build dependencies when building chromium

Attached to Project: Arch Linux
Opened by John (graysky) - Friday, 29 October 2021, 17:22 GMT
Last edited by Antonio Rojas (arojas) - Friday, 29 October 2021, 19:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am unable to build chromium-95.0.4638.69-1 due to unresolvable dependencies relating to ffmpeg. Not sure if this is to do with ffmpeg or chromium.

% makechrootpkg -u -c -d /scratch/.distcc:/build/.distcc -r /scratch/.buildroot

...

==> Making package: chromium 95.0.4638.69-1 (Fri 29 Oct 2021 01:15:58 PM EDT)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
warning: cannot resolve "libvpx.so=6-64", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=161-64", a dependency of "ffmpeg"
:: The following package cannot be upgraded due to unresolvable dependencies:
ffmpeg

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libvpx.so=6-64' required by ffmpeg
:: unable to satisfy dependency 'libx264.so=161-64' required by ffmpeg
==> ERROR: 'pacman' failed to install missing dependencies.
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 29 October 2021, 19:56 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 29 October 2021, 19:37 GMT
Looks like it's trying to install an old version of ffmpeg. Bad mirror? Bad pacman config?
Comment by John (graysky) - Friday, 29 October 2021, 19:49 GMT
Bad mirror. Sorry for the bogus report.

Loading...