Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72578 - pacman doesn't show download progress correctly

Attached to Project: Arch Linux
Opened by Mohammad Nabil (mnabil.net) - Friday, 29 October 2021, 17:02 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 15 November 2021, 19:41 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
pacman doesn't show download progress correctly, it is 0% or 100% after download completes

Additional info:
* package version(s)
Linux linux 5.14.14-arch1-1 #1 SMP PREEMPT Wed, 20 Oct 2021 21:35:18 +0000 x86_64 GNU/Linux
.--. Pacman v6.0.1 - libalpm v13.0.1
/ _.-' .-. .-. .-. Copyright (C) 2006-2021 Pacman Development Team
\ '-. '-' '-' '-' Copyright (C) 2002-2006 Judd Vinet
'--'
This program may be freely redistributed under
the terms of the GNU General Public License.

* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
pacman -Syyu
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 15 November 2021, 19:41 GMT
Reason for closing:  No response
Additional comments about closing:  probably a faulty mirror
Comment by Allan McRae (Allan) - Saturday, 30 October 2021, 03:53 GMT
What mirror are you using?
Comment by Max (Conusoid) - Wednesday, 10 November 2021, 09:14 GMT
I have the same issue for the last 2 weeks. The progress bar shows 0% until a package is fully downloaded, then progress becomes 100% and so on. It doesn't show download speed as well. So, If the package is large enough, it may appear that the process is frozen.
Attaching my mirrorlist file. Though, I'm using reflector, so the list is changing every week.
Edit: Probably, after all, the problem was in one of the mirrors. As of today, the progress bar is working fine.

Loading...