Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72545 - [bluez] Mouse fails to connect first time

Attached to Project: Arch Linux
Opened by RW (gdi) - Monday, 25 October 2021, 22:50 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 06 December 2021, 10:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I use a Bluetooth mouse, and after booting, it will not connect properly with a "profiles/input/hog-lib.c:set_report_cb() Error setting Report value: Unexpected error code". I need to enable/disable it to get it to connect. Downgrading to 5.61 solves the issue for me.

Additional info:
* package version: 5.62-1
* link to upstream bug report, if any: Not a bug report, but this reddit thread details it better than I have: https://www.reddit.com/r/linuxquestions/comments/qcb9cl/bluez_562_fails_to_connect_mouse_on_first_try/
Relevant quote from it:
[EDIT] The cause of the issue has at least been found. It dates to a commit from earlier this month, specifically ac2c2e10b3adb432a572b618c6f53cabb6b3c80b, where bt_att_resend was being implemented into attrib/gattrib.c.
[EDIT] If you have this problem too, you can fix this by rebuilding BlueZ after rolling back the offending file. git checkout 4284184d00 -- attrib/gattrib.c

Steps to reproduce:
1. Connect Bluetooth mouse with Bluetooth.
2. Reboot.
3. Mouse fails to connect first try.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 06 December 2021, 10:36 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Tuesday, 02 November 2021, 17:55 GMT
Please report this upstream. The bug won't get fixes magically when upstream isn't aware of it.
Comment by RW (gdi) - Friday, 05 November 2021, 23:12 GMT
Want to first apologize, as I somehow misread this(multiple times) as just needing a recompile with a later commit, not a rollback. Need to stop skimming I guess.

And also want to add a couple relevant upstream bug reports. I couldn't find the 'Issues' section on the kernel.org site. Didn't know there was a github one too. lol...
https://github.com/bluez/bluez/issues/220
https://github.com/bluez/bluez/issues/227

Loading...