Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#72536 - [pacman] cannot handle conflicts when two packages are installed and later conflicts after update

Attached to Project: Pacman
Opened by Shrinivas Kumbhar (Librewish) - Monday, 25 October 2021, 06:51 GMT
Last edited by Allan McRae (Allan) - Monday, 25 October 2021, 09:54 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
currently pacman is unable to handle conflicts that arise after updates to packages that are installed and they conflict afterwards when packaging changes
for ex
two packages are installed say wireplumber and pipewire-media-session they dont conflict but they get updated and they conflict due to the changes. now system wont update due to both of them got updated and are in conflict.

so what pacman should do is when two packages conflict it should prompt for removal of packages with options.
like how it gives option for when multiple packages provide same thing.
pkg1 and pkg2 conflicts. select the package you want to remove(or keep)
1. pkg1
2. pkg2
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 25 October 2021, 09:54 GMT
Reason for closing:  Won't implement
Comment by Allan McRae (Allan) - Monday, 25 October 2021, 08:07 GMT
That sounds like poor packaging to me. wireplumber conflicts and provides pipewire-media-session. It should also replace pipewire-media-session.

With proper packaging, pacman will ask to remove pipewire-media-session. Not a pacman issue.
Comment by Shrinivas Kumbhar (Librewish) - Monday, 25 October 2021, 08:10 GMT
it is not meant to replace
its an alternative.

and is not a poor packaging

thats just how it is and pacman should handle this case
as this will happen again and again with differnt set of packages when they get updated and provide things later.

dont just shrug it off as not a pacman issue
Comment by Morten Linderud (Foxboron) - Monday, 25 October 2021, 09:32 GMT
  • Field changed: Percent Complete (100% → 0%)
pipewire-media-session and wireplumber are interchangeable alternatives. There shouldn't be a replaces here.
Comment by Allan McRae (Allan) - Monday, 25 October 2021, 09:53 GMT
There is no file conflicts. Why is there a conflict in pipewire-media-session?

Anyway, I'm of the opinion that this is not something pacman should handle. I'll re-close as Won't Implement.

Loading...