Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72515 - [tesseract] eng and osd are not optional dependencies

Attached to Project: Community Packages
Opened by Felix Breidenstein (fleaz) - Friday, 22 October 2021, 14:42 GMT
Last edited by Caleb Maclennan (alerque) - Tuesday, 01 February 2022, 09:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Caleb Maclennan (alerque)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
According to one of the maintainers, the trainingdata for OSD and ENG are required dependencies, but they are marked as optional and won't get installed. Not having them installed indeed breaks some tesseract commands.

Additional info:
* link to upstream bug report: https://github.com/tesseract-ocr/tesseract/issues/3605#issuecomment-949678384


Steps to reproduce:
Install "tesseract" from community repo, which won't install any trainingdata packages. Then run "tesseract --list-langs"
This task depends upon

Closed by  Caleb Maclennan (alerque)
Tuesday, 01 February 2022, 09:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Was valid at time of reporting, but is no longer true and not an issue that needs fixing now.
Comment by Caleb Maclennan (alerque) - Tuesday, 01 February 2022, 09:09 GMT
OSD is fixed (see  FS#71607 ). I'm still trying to make out if ENG is required in Tesseract 5 or not.
Comment by Caleb Maclennan (alerque) - Tuesday, 01 February 2022, 09:14 GMT
I am closing this because it is no longer valid. It *was* a valid report at the time it was opened and true for the Tesseract 4 releases, but Tesesract 5.x works fine with any one language installed without ENG. OSD is required, but I cat install TUR and use it just fine without ENG installed.

The current packaging has been updated to require at least one of the language packages. All of them are still optdepends, but at least one must me provided.

Loading...