Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72483 - [wget] sends 'SSL_INIT' to stderr even with -q

Attached to Project: Arch Linux
Opened by Mathias Rohnstock (mrohnstock) - Wednesday, 20 October 2021, 06:29 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 24 March 2022, 17:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
since the update to 1.21.2 wget will send an 'SSL_INIT' to stderr, even with using the -q flag.

Additional info:
* package version(s): 1.21.1
* upstream bug report: https://savannah.gnu.org/bugs/?61125

Steps to reproduce:
wget -q https://www.google.com -O /dev/null

see on stderr:
SSL_INIT

Solution:
there is already a patch for this issue since about 1 month in the git repo: https://git.savannah.gnu.org/cgit/wget.git/patch/?id=3ea9658c072fa1dc87aec7af45393b46904b143f
Could we (maybe) add this patch to our package in the meanwhile, until a new release will appear of wget?
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 24 March 2022, 17:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  wget 1.21.3
Comment by . (-_-) - Friday, 11 March 2022, 10:19 GMT
wget has been out of date for whole months, and it looks like this has been fixed?

https://lists.gnu.org/archive/html/bug-wget/2022-02/msg00025.html
"** Remove a spurious print statement that showed up even during --quiet"
Comment by Theodor R. (theor) - Friday, 11 March 2022, 18:52 GMT
1.21.3 got released on February 26, fixing this issue. So there's now no need to backport the patch, just update the package to 1.21.3.

Before that the patch was sitting on the master branch for several months, waiting to be released.
Comment by Bernd Rothert (bro) - Wednesday, 16 March 2022, 12:30 GMT
If this still bugs you (like me) and you need a quickfix for wget-1.21.2-1 on x86_64:

# sed -i.orig -e 's#AW\xba\t#AW\xba\x00#' /usr/bin/wget

;-)

Loading...