Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#72480 - [python-readme-renderer] version 0.29 is incompatible with python-cmarkgfm 0.6.0

Attached to Project: Community Packages
Opened by Benoit Pierre (bpierre) - Tuesday, 19 October 2021, 16:23 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 02 November 2021, 19:06 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No



`python-readme-renderer 29.0-1` is not compatible with `python-cmarkgfm 0.6.0-1`, so trying to use a Python package depending on `readme-renderer[md]` will fail with:
pkg_resources.VersionConflict: (cmarkgfm 0.6.0 (/usr/lib/python3.9/site-packages), Requirement.parse('cmarkgfm<0.6.0,>=0.5.0'))

This is fixed in `readme-renderer 30.0`:
This task depends upon

Comment by Benoit Pierre (bpierre) - Monday, 13 December 2021, 19:10 GMT
Here is a patch updating to python-readme-renderer to 32.0.