Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7247 - Pacman Segmentation Fault

Attached to Project: Pacman
Opened by Bob Red (neosenate) - Wednesday, 23 May 2007, 16:28 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 16 January 2008, 22:48 GMT
Task Type Bug Report
Category Backend/Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version 3.0.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
When attempting to synchronise with the DB and perform a full system update, pacman will throw a segmentation fault error.

Link to forums - http://bbs.archlinux.org/viewtopic.php?pid=252395#p252395

Steps to Reproduce:
Run the command #pacman -Suy
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 16 January 2008, 22:48 GMT
Reason for closing:  Works for me
Additional comments about closing:  Old bug, please re-report later if it reappears
Comment by Andrew Fyfe (space-m0nkey) - Wednesday, 23 May 2007, 22:57 GMT
debug log from 'pacman --debug=2 --noconfirm -Sy gnome-extra'.
Comment by Aaron Griffin (phrakture) - Wednesday, 23 May 2007, 23:01 GMT
Thanks Andrew, I will look into this.
Comment by Aaron Griffin (phrakture) - Thursday, 24 May 2007, 03:04 GMT
here's an oddity...
using this sample program here: http://phraktured.net/libdownload/samples/

sometimes it hangs, and times out, sometimes it does not... I don't know if that's related or not
Comment by Roman Kyrylych (Romashka) - Thursday, 24 May 2007, 07:46 GMT
how about checking libdownload for memory allocation/freeing issues (valgrind?)
Comment by Andrew Fyfe (space-m0nkey) - Thursday, 24 May 2007, 11:21 GMT
What options should I run valgrind with?
Comment by Andrew Fyfe (space-m0nkey) - Thursday, 24 May 2007, 12:18 GMT
Hopefully I've used the right options and this is of use.
Comment by Abelardo Tordo (atordo) - Thursday, 24 May 2007, 13:47 GMT
This is the output of "pacman --noconfirm --debug=2 -S antiword > pacman-segfault 2>&1". Note that despite the seg fault, the package was correctly installed (or so it seems).
Comment by Anton Fiuman (lexiw) - Thursday, 28 June 2007, 14:14 GMT
I've picked a random unsupported repository from the wiki:
[Victor]
Server = http://personales.ya.com/vmromanos/arch/pkgs

[lexiw@stroggos pacman]$ sudo pacman -Sy
:: Synchronizing package databases...
Internal pacman error: Segmentation faults 00:00:00 [---------------------] 0%
Please submit a full bug report, with the given package if appropriate.
Comment by Dan McGee (toofishes) - Wednesday, 16 January 2008, 05:21 GMT
Stagnant bug report. Has anyone seen this in a while? Otherwise it is worthy of closure after our version bump.

Loading...