Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72459 - Black screen with totally responsive pointer and keyboard after upgrading to Plasma 5.23

Attached to Project: Arch Linux
Opened by Lucas Rizzini (lucasrizzini) - Sunday, 17 October 2021, 19:19 GMT
Last edited by Antonio Rojas (arojas) - Monday, 18 October 2021, 16:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I tried to open some GUI applications through another TTY using DISPLAY=:0 environment variable attribution with no luck. CTRL+ALT+DEL open the shutdown screen, right? It appears somewhere since I can just press enter and shut down the machine, but it doesn't appear on my screen. I'm on X11.

Another user had the same issue and stated that it's working fine on Wayland-> https://www.reddit.com/r/archlinux/comments/qa485a/black_screen_with_totally_responsive_pointer_and/


Additional info:
* Plasma 5.23.0-1 from upstream
* I restarted sddm with journalctl --follow running -> File attached to the report.

Specs:



Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 18 October 2021, 16:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  kwin 5.23.0-2
Comment by Antonio Rojas (arojas) - Sunday, 17 October 2021, 19:51 GMT
Please report upstream
Comment by Martin Rys (C0rn3j) - Monday, 18 October 2021, 11:19 GMT Comment by Antonio Rojas (arojas) - Monday, 18 October 2021, 11:29 GMT
please test kwin 5.23.0-2
Comment by Lucas Rizzini (lucasrizzini) - Monday, 18 October 2021, 11:41 GMT
I tested KWin 5.23.0-2 and 5.23.0-1. Same behavior on both.
Comment by Lucas Rizzini (lucasrizzini) - Monday, 18 October 2021, 16:39 GMT
The problem was the Command Output widget(print) at my taskbar. I just removed it before the upgrade and it's all fine now. I even added it again.

Command Output widget -> https://github.com/Zren/plasma-applet-commandoutput
Print -> https://i.imgur.com/Z5m8tk5.png
Comment by Lucas Rizzini (lucasrizzini) - Monday, 18 October 2021, 16:48 GMT
I didn't have to update the widget, just removed it from my taskbar before the upgrade and added it again after.

Loading...