Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72440 - [hwinfo] 21.77-1 conflicts with "filesystem" package due to containing empty folder(s)

Attached to Project: Community Packages
Opened by Kr1ss X (Kr1ss) - Saturday, 16 October 2021, 12:21 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Saturday, 16 October 2021, 19:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 35
Private No

Details

Description:
Version 21.77-1 packages the (empty) directories `sbin/` and `var/lib/hardware/udi`.
At least the former one leads to a conflict with the `filesystem` package.

Additional info:
* package version(s) : hwinfo-21.77-1

Steps to reproduce:
Install `hwinfo-21.77-1` from [community] on a system with `filesystem` installed. This fails with the following error output.

```
error: failed to commit transaction (conflicting files)
hwinfo: /sbin exists in filesystem (owned by filesystem)
Errors occurred, no packages were upgraded.
```
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Saturday, 16 October 2021, 19:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  hwinfo-21.77-2
Comment by AMM (amish) - Saturday, 16 October 2021, 12:22 GMT
This is due to removal of line options=(!emptydirs) from PKGBUILD.

I always wonder if maintainers release some packages without testing on their own system?
Comment by Troy Engel (TE) - Saturday, 16 October 2021, 12:41 GMT Comment by Filipe Laíns (FFY00) - Saturday, 16 October 2021, 14:46 GMT
The last step of extra-x86_64-build, where it tries to install the package, should have failed. I don't really understand how this got released, perhaps the maintainer just didn't notice?
Comment by Max Paluska (umaxtu) - Saturday, 16 October 2021, 15:58 GMT
This broke my system when I forced the upgrade (I'm stupid). Thankfully I had snapper setup with grub so I could easily roll it back
Comment by Frederick Zhang (FrederickZh) - Saturday, 16 October 2021, 16:02 GMT
@Max I'm not totally sure but simply re-linking `/sbin` to `usr/bin` should work? Rollback sounds like an overkill.
Comment by Xuanrui Qi (xuanrui) - Saturday, 16 October 2021, 17:27 GMT
or just `rmdir ${pkgdir}/sbin`.
Comment by Alexander F. Rødseth (xyproto) - Saturday, 16 October 2021, 19:08 GMT
Thanks for reporting, the updated package will appear in [community] shortly.

Loading...