Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72423 - openmw 0.47.0rc-2 missing dependency (boost-libs)

Attached to Project: Arch Linux
Opened by roberto fucking machoman (rfm23) - Thursday, 14 October 2021, 18:08 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Friday, 15 October 2021, 04:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
openmw-launcher from openmw 0.47.0rc-2 fails with this error:
openmw-launcher: error while loading shared libraries: libboost_filesystem.so.1.76.0: cannot open shared object file: No such file or directory

openmw has "boost(make)" listed as a dependency but that package doesn't contain any .so's, however boost-libs has libboost_filesystem.so.1.76.0, installing that package allowed me to run the game.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
try to run openmw launcher without boost-libs installed
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Friday, 15 October 2021, 04:34 GMT
Reason for closing:  Fixed
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 14 October 2021, 21:36 GMT
Should be fixed, can you check?
Comment by roberto fucking machoman (rfm23) - Friday, 15 October 2021, 04:00 GMT
I uninstalled openmw and boost-libs with pacman -Rns, then reinstalled openmw and it works.

Loading...