Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72405 - [mariadb] config directory /etc/my.cnf.d/ ignored

Attached to Project: Arch Linux
Opened by john knillenhower (knille) - Tuesday, 12 October 2021, 14:53 GMT
Last edited by Christian Hesse (eworm) - Thursday, 14 October 2021, 20:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

with mariadb 10.6.4-1 the config files in directory /etc/my.cnf.d/ are ignored. when i do "mysqld --help --verbose | less", i get:

> mysqld Ver 10.6.4-MariaDB-log for Linux on x86_64 (Arch Linux)
> Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
>
> Starts the MariaDB database server.
>
> Usage: mysqld [OPTIONS]
>
> Default options are read from the following files in the given order:
> /etc/my.cnf ~/.my.cnf
> The following groups ...

i don't know whether this is a package issue or a problem with my configuration. the arch wiki states that the directory should be included:
https://wiki.archlinux.org/title/MariaDB#Configuration_files

i also described the issue in the arch forum but no reply so far:
https://bbs.archlinux.org/viewtopic.php?id=269972




This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 14 October 2021, 20:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  as expected, behavior caused by local configuration
Comment by Christian Hesse (eworm) - Thursday, 14 October 2021, 20:37 GMT
The default configuration file /etc/my.cnf contains these lines:

[client-server]
!includedir /etc/my.cnf.d

Which includes the files from that directory. Looks like you have a modified configuration file that does not.

Loading...