Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72403 - nvidia-settings - ERROR: Unable to load info from any available system

Attached to Project: Arch Linux
Opened by John Moe (JakeMoe) - Tuesday, 12 October 2021, 08:07 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Friday, 05 November 2021, 19:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After installing nvidia-settings, when I tried to run it, I got "ERROR: Unable to load info from any available system". Googling led me to this post on Nvidia's forums: https://forums.developer.nvidia.com/t/nvidia-settings-error-unable-to-load-info-from-any-available-system/172872/4

As I've recently migrated from Gentoo, where nvidia-settings worked, I checked the ebuild there, and sure enough, it created a "50-nvidia-drm-outputclass.conf" in /etc/X11/xord.conf.d that was pretty much exactly what that Nvidia post said. When I added it to my system (with a modified lib path of /usr/lib/nvidia/xorg since that seems to be where the modules are) and restarted Xorg, nvidia-settings worked.

Additional info:
* package version(s) - nvidia-settings 470.74-1
* config and/or log files etc. - see info above
* link to upstream bug report, if any - see info above
* system info - Dell Latitude 5520 with i7 Iris Xe iGPU and Nvidia GeForce MX450 dGPU

Steps to reproduce:
1. pacman -S nvidia-settings
2. nvidia-settings
3. Receive error
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Friday, 05 November 2021, 19:51 GMT
Reason for closing:  Won't fix
Additional comments about closing:  2021-11-05: A task closure has been requested. Reason for request: Issue has not re-occurred since last fix
Comment by John Moe (JakeMoe) - Wednesday, 13 October 2021, 07:32 GMT
Hmm, restarted my computer today to the same error. Restarted Xorg again (exit FVWM back to lightdm, then log back in), and it worked fine. Checking my Xorg.0.log, it looks like it's pulling that module path in twice; once with a few other paths, and once on it's own, I presume my addition is the second one. The first boot Xorg.0.log had neither. So it looks like something else is going on here, and it was simply restarting Xorg that fixed it, not my conf file.

Extract from working Xorg.0.log:
[ 3333.502] (==) ModulePath set to "/usr/lib/xorg/modules"
...
[ 3333.516] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[ 3333.516] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"

Will continue to test and let you know how I go.
Comment by loqs (loqs) - Wednesday, 13 October 2021, 07:40 GMT
Have you tried enabling early KMS to ensure the nvidia-drm module is loaded before X starts so /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf will match and extend the module path?

[1] https://wiki.archlinux.org/title/Kernel_mode_setting#Early_KMS_start
Comment by John Moe (JakeMoe) - Wednesday, 13 October 2021, 08:41 GMT
No, I didn't know what DRM KMS would do for me when I followed the guide, so I skipped for now; figured I'd find out later if I needed. Apparently, later is now.

I've had a read of the link you sent, which sent me to this, which sounded like it needed to be set up first: https://wiki.archlinux.org/title/NVIDIA#DRM_kernel_mode_setting

I followed those instructions (adding nvidia-drm.modeset=1 to GRUB command line) and rebooted, and I see the ModulePath loading, and nvidia-settings works. Will check again later from a cold boot to be sure, but hopefully that sorts my issue out. Cheers.
Comment by John Moe (JakeMoe) - Friday, 15 October 2021, 07:15 GMT
Well, when I booted up today, I had the same issue, so I've now added the Intel and Nvidia modules listed in your Early KMS Start link as described and regenerated my initramfs. Will let you know how it goes.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 05 November 2021, 05:23 GMT
Is there any further update on this? Nvidia added some module order loading fixes to 495 for exactly this issue judging by the release notes.
Comment by John Moe (JakeMoe) - Friday, 05 November 2021, 06:36 GMT
Sorry, I forgot to come back to this; I haven't had any issues since my last post, so I presume the Early KMS Start link fixed my issue.

Loading...