Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72380 - [julia 1.6.3-1] julia package manager is incompatible to libgit 1.2.0

Attached to Project: Community Packages
Opened by Simon Adrian (Vogelweide) - Sunday, 10 October 2021, 12:31 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 10 October 2021, 14:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After the upgrade from libgit2 1:1.1.1-1 => 1:1.2.0-1 and libgit2-glib 0.99.0.1-5 => 0.99.0.1-6 the Julia package manager stopped working: updating the packages results in a GitError.

Additional info:
* package version: julia 1.6.3-1, libgit2 1:1.2.0-1 and libgit2-glib 0.99.0.1-6
* link to upstream bug report: this report might be related https://discourse.julialang.org/t/cannot-clone-on-julia-1-6-3/68757

Steps to reproduce:

1) Start Julia
2) Enter the Pkg REPL by pressing ] from the Julia REP
3) Execute "update" command

Result:

(@v1.6) pkg> update
Updating registry at `~/.julia/registries/General`
Updating git-repo `https://github.com/JuliaRegistries/General.git`
┌ Warning: Some registries failed to update:
│ — /home/simon/.julia/registries/General — failed to fetch from repo
└ @ Pkg.Types /build/julia/src/julia-1.6.3/usr/share/julia/stdlib/v1.6/Pkg/src/Types.jl:1246
Updating git-repo `https://github.com/JuliaMatrices/SpecialMatrices.jl.git`
ERROR: failed to fetch from https://github.com/JuliaMatrices/SpecialMatrices.jl.git, error: GitError(Code:ERROR, Class:Invalid, invalid version 0 on git_proxy_options)

Solution: One can downgrade libgit2 again, however, this breaks other programs such as "kate". In the current state, however, julia can barely be used productively.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 10 October 2021, 14:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  julia 1.6.3-2

Loading...