Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72269 - Unable to interact with git repositories due to latest libgit2 package update: no matching host key

Attached to Project: Arch Linux
Opened by Fran Dieguez (frandieguez) - Tuesday, 28 September 2021, 09:07 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 28 September 2021, 09:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Unable to download from ssh git repositories after upgrading libgit to 1.2.0 with package versions as shown below

libgit2 1 1.2.0
libgit2-glib 0.99.0+2+g0c28c3a

Today I've updated my system including the previous packages and versions.


Steps to reproduce:
- Upgrade to libgit2
- Go to terminal and issue: git clone git@github.com:situmtech/situm-android-getting-started.git, the next message will appear
```
➜ git pull
Unable to negotiate with 104.192.141.1 port 22: no matching host key type found. Their offer: ssh-rsa,ssh-dss
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
```


Downgrading to previous versions fixes the problem
```
warning: downgrading package libgit2 (1:1.2.0-1 => 1:1.1.1-1)
warning: downgrading package libgit2-glib (0.99.0.1-6 => 0.99.0.1-5)
```
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 28 September 2021, 09:24 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Tuesday, 28 September 2021, 09:24 GMT
The git command has nothing to do with libgit2. This is caused by the openssh update, see https://www.openssh.com/txt/release-8.8

Loading...