Attached to Project: Community Packages
Opened by John (graysky) - Monday, 27 September 2021, 18:18 GMT
Last edited by Toolybird (Toolybird) - Sunday, 14 May 2023, 03:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


Recently, running iotop displays a warn and does not behave as it did in the past. The warning is, "CONFIG_TASK_DELAY_ACCT not enabled in kernel, cannot determine SWAPIN and IO %" and I am see a loss of output in the display relating to these two items. Interestingly, this option is in fact enabled in the kernel. Packaging bug? Upstream bug?

% zgrep -i task_delay /proc/config.gz

Additional info:
* package version(s) iotop 0.6-8
This task depends upon

Closed by  Toolybird (Toolybird)
Sunday, 14 May 2023, 03:52 GMT
Reason for closing:  Not a bug
Additional comments about closing:  It's a config issue.
Comment by loqs (loqs) - Wednesday, 06 October 2021, 18:31 GMT
Have you tried applying the commits below? ( Note ab35334d374e588bec12d201fb8869c536f0545d does not apply cleanly without manual adjustment )

Comment by John (graysky) - Wednesday, 06 October 2021, 19:19 GMT
I applied both after adjusting them (see attached single) but it did not fix the bug.
Comment by loqs (loqs) - Wednesday, 06 October 2021, 20:00 GMT
Did you also set the sysctl kernel.task_delayacct to 1?
Comment by John (graysky) - Thursday, 07 October 2021, 08:30 GMT
I did now. Using the patch and setting the variable to 1 gives the expected behavior.
Comment by John (graysky) - Tuesday, 30 November 2021, 13:01 GMT
Is it possible to add the [kernel] tag to this FS? Seems like toggling the setting for basic functionality is a work-around/should be set in the kernel config unless there are downsides.
Comment by Jaroslav Lichtblau (Dragonlord) - Saturday, 05 February 2022, 18:22 GMT
is this issue still present, or gone by now?
quick start of iotop on my machine, I don't see any warnings
Comment by Simon Perry (pezz) - Sunday, 06 February 2022, 01:51 GMT
I still get the CONFIG_TASK_DELAY_ACCT not enabled message.
Comment by Simon Perry (pezz) - Sunday, 06 February 2022, 01:56 GMT
Although I just noticed graysky's comment. Setting kernel.task_delayacct=1 makes it work.