Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72253 - [coreutils] chmod -R returns wrong exit-code

Attached to Project: Arch Linux
Opened by Alexander Schnaidt (Namarrgon) - Monday, 27 September 2021, 12:47 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 14 October 2021, 21:48 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To S├ębastien Luttringer (seblu)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
chmod from 'coreutils 9.0-1' returns a wrong exit-code when it encounters symlinks in recursive operations.

Upstream bugreport and patch:
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=50784
http://git.savannah.gnu.org/gitweb/?p=coreutils.git;a=commit;h=e8b56ebd536e82b15542a00c888109471936bfda

Downgrading to the previous version "fixes" the bug.
Reported by das_j on irc who ran into the same issue on nixos.

Steps to reproduce:
Update to coreutils 9.0-1 and attempt to build any of the following:
community/uglify-js
community/typescript
community/semver

or any other package that uses 'chmod -R' over a directory structure that contains symlinks. This obviously also includes other uses of chmod in any script the user or system runs.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 14 October 2021, 21:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  2021-10-12: A task closure has been requested. Reason for request: Fixed: coreutils 9.0-2
Comment by S├ębastien Luttringer (seblu) - Wednesday, 29 September 2021, 14:15 GMT
coreutils-9.0-2 is in testing.
Comment by Chris Severance (severach) - Friday, 01 October 2021, 01:35 GMT
9.0-1 broken for me compiling linux-lts419. Only broken when running chroot fakeroot. Non chroot fakeroot still works. All fixed in 9.0-2.

Edit: outside only worked because it hadn't upgraded to 9.0-1 yet. Upgrade and it fails everywhere.

linux-lts419 comments

darnrain commented on 2021-09-30 10:07
I cant seem to compile the new 4.19.208 I am getting an error message
==> ERROR: A failure occurred in package_linux-lts419-headers(). Aborting...
Anyone have any idea on how to fix this?

bloat commented on 2021-09-29 23:27
Stripping build tools... Adding symlink... Fixing permissions... ==> ERROR: A failure occurred in package_linux-lts419-headers(). Aborting... error making: linux-lts419

Loading...