Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#72246 - Pacman exit 0 on 404 or 403 of only 1 or two packages

Attached to Project: Pacman
Opened by Ryan Kuba (thelamer) - Monday, 27 September 2021, 01:07 GMT
Last edited by Allan McRae (Allan) - Monday, 27 September 2021, 11:11 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 6.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
When running pacman and only one or two packages is not found on the mirror it is using it will exit 0. IE:
`error: failed retrieving file 'tracker3-3.2.0-1-aarch64.pkg.tar.xz' from mirror.archlinuxarm.org : The requested URL returned error: 404

warning: failed to retrieve some files

error: failed to commit transaction (failed to retrieve some files)

Errors occurred, no packages were upgraded.

`

Steps to Reproduce:
There are many ways, but none by running a series of commands on the client. You would need to hit a local mirror and intentionally remove the package or a simple proxy that 404's a single request.
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 27 September 2021, 11:11 GMT
Reason for closing:  Not a bug

Loading...