Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72204 - Error during boot: 'Failed to start Load/save random seed'

Attached to Project: Arch Linux
Opened by Arun (arun321) - Wednesday, 22 September 2021, 06:05 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 28 September 2021, 09:25 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Every time error (systemd?) shows "Failed to start Load/save random seed" when booting arch Linux. It started to show after updating kernel from 5.12.x to 5.14.x

Additional info:

Standard arch kernel and systemd from arch repos. Compiling kernel with CONFIG_RANDOM_TRUST_CPU=y fixes the error. The other way to remove the error is to disable tpm.

https://systemd.io/RANDOM_SEEDS/



Steps to reproduce:

1. enable secure boot and tpm
2. systemd-random-seed.service fails to start.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 28 September 2021, 09:25 GMT
Reason for closing:  Works for me
Comment by Arun (arun321) - Wednesday, 22 September 2021, 07:38 GMT
"The other way to remove the error is to disable tpm." disabling tpm doesn't fix it.
Comment by Arun (arun321) - Friday, 24 September 2021, 05:21 GMT Comment by loqs (loqs) - Friday, 24 September 2021, 22:56 GMT
What is the result if you add the kernel parameter random.trust_cpu=on instead of rebuilding the kernel with CONFIG_RANDOM_TRUST_CPU=y ?
Comment by Arun (arun321) - Monday, 27 September 2021, 16:25 GMT
I have already tried using random.trust_cpu=on kernel parameter. it doesn't work and I still get service error.
Comment by loqs (loqs) - Monday, 27 September 2021, 18:51 GMT
random.trust_cpu=on overrides CONFIG_RANDOM_TRUST being unset and is equivalent to CONFIG_RANDOM_TRUST_CPU=y
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/drivers/char/random.c?h=v5.14.8#n767
Comment by Arun (arun321) - Tuesday, 28 September 2021, 04:54 GMT
I have reinstalled arch also I have disabled secure boot and TPM. Now everything works fine even without random.trust_cpu=on.

Loading...