Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72200 - [git-delta] add libgit2.so as dependency

Attached to Project: Community Packages
Opened by Axel Navarro (navarroaxel) - Tuesday, 21 September 2021, 18:00 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 21 September 2021, 18:25 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After update manually from libgit2-1:1.1.1-1 to libgit2-1:1.2.0-1 the delta command throws the following error:

```
/usr/bin/delta: error while loading shared libraries: libgit2.so.1.1: cannot open shared object file: No such file or directory
```

Pacman should throw the same error when you try to update libgit2 and isn't compatible with the installed Starship version, but for the git-delta package

```
warning: cannot resolve "libgit2.so=1.2-64", a dependency of "starship"
:: The following package cannot be upgraded due to unresolvable dependencies:
starship

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libgit2.so=1.2-64' required by starship
```

Additional info:
* package version(s)
git-delta-0.8.3-1
libgit2-1:1.2.0-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
In stable channel install libgit2 and git-delta
Update to testing version libgit2-1:1.2.0-1
Try to run git-delta
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 21 September 2021, 18:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  partial updates are not supported

Loading...