Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72197 - Failed to initialize NVML: Driver/library version mismatch

Attached to Project: Arch Linux
Opened by Riyadul Islam Mollick (riyadulmollick) - Tuesday, 21 September 2021, 16:27 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Tuesday, 28 September 2021, 11:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Nvidia Driver doesn't work correctly, When I type $nvidia-smi, it shows me "Failed to initialize NVML: Driver/library version mismatch" this error.


Additional info:
* Kernel
1) linux 5.14.6-arch1-1

* package version(s)
1) nvidia 470.74-1
2) nvidia-utils 470.74-1
3) nvidia-dkms 470.74-1

* config and/or log files etc.
cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 470.74.01 Tue Aug 3 20:44:16 UTC 2021
GCC version: gcc version 11.1.0 (GCC)

* link to upstream bug report, if any
reddit bug link: https://www.reddit.com/r/archlinux/comments/psfkqt/be_careful_with_upgrading_nvidiadkms_and/?utm_source=share&utm_medium=web2x&context=3

Steps to reproduce:
1. Type nvidia-smi into terminal. It will shows this error.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Tuesday, 28 September 2021, 11:00 GMT
Reason for closing:  No response
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 21 September 2021, 19:09 GMT
Did you reboot after the driver upgrade? As with kernel upgrades, for binary blob driver updates you need to reboot.
Comment by Riyadul Islam Mollick (riyadulmollick) - Wednesday, 22 September 2021, 02:57 GMT
Yes, I did. But then the problem occurs.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 23 September 2021, 15:04 GMT
I can't reproduce this at all. Need more specific instructions. I always run my own drivers and there doesn't appear to be any problem.

Loading...