Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72190 - keyboard malfunction on kernel 5.14.6-arch1-1

Attached to Project: Arch Linux
Opened by Andrea (Snaporaz) - Tuesday, 21 September 2021, 09:09 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 14 October 2021, 21:49 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
F-key are not recognized anymore when using my external keyboard (iqunix f96), it looks like an fn-lock is activated.
Using 5.10.67-1-lts fixes the problem.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Host: 20HQS3MR00 ThinkPad X1 Carbon 5th

Taken directly from /dev/input/event pressing F1,...,F12 (for simplicity I removed the release signals)
[code]
Event: time 1632203696.261431, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203697.010130, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203697.471346, type 1 (EV_KEY), code 120 (KEY_SCALE), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203697.932608, type 1 (EV_KEY), code 204 (KEY_DASHBOARD), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203698.269897, type 1 (EV_KEY), code 229 (KEY_KBDILLUMDOWN), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203698.596557, type 1 (EV_KEY), code 230 (KEY_KBDILLUMUP), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203698.911333, type 1 (EV_KEY), code 165 (KEY_PREVIOUSSONG), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203699.226151, type 1 (EV_KEY), code 164 (KEY_PLAYPAUSE), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203699.541300, type 1 (EV_KEY), code 163 (KEY_NEXTSONG), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203699.856490, type 1 (EV_KEY), code 113 (KEY_MUTE), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203700.171402, type 1 (EV_KEY), code 114 (KEY_VOLUMEDOWN), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632203700.542597, type 1 (EV_KEY), code 115 (KEY_VOLUMEUP), value 1
[/code]

However not all of them are the same as when I use the Fn key on the same keyboard

[code]
Event: time 1632204126.380761, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1
Event: time 1632204126.380761, -------------- SYN_REPORT ------------
Event: time 1632204127.257923, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1
Event: time 1632204127.348019, -------------- SYN_REPORT ------------
Event: time 1632204127.966849, type 1 (EV_KEY), code 120 (KEY_SCALE), value 1
Event: time 1632204128.068129, -------------- SYN_REPORT ------------
Event: time 1632204128.563064, type 1 (EV_KEY), code 204 (KEY_DASHBOARD), value 1
Event: time 1632204128.653147, -------------- SYN_REPORT ------------
Event: time 1632204129.035757, type 1 (EV_KEY), code 229 (KEY_KBDILLUMDOWN), value 1
Event: time 1632204129.136788, -------------- SYN_REPORT ------------
Event: time 1632204129.496878, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00b6
Event: time 1632204129.496878, type 1 (EV_KEY), code 165 (KEY_PREVIOUSSONG), value 1
Event: time 1632204129.575563, -------------- SYN_REPORT ------------
Event: time 1632204130.059397, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00b5
Event: time 1632204130.059397, type 1 (EV_KEY), code 163 (KEY_NEXTSONG), value 1
Event: time 1632204130.194252, -------------- SYN_REPORT ------------
Event: time 1632204130.689311, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00cd
Event: time 1632204130.689311, type 1 (EV_KEY), code 164 (KEY_PLAYPAUSE), value 1
Event: time 1632204130.790535, -------------- SYN_REPORT ------------
Event: time 1632204131.274188, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00e2
Event: time 1632204131.274188, type 1 (EV_KEY), code 113 (KEY_MUTE), value 1
Event: time 1632204131.375539, -------------- SYN_REPORT ------------
Event: time 1632204133.108068, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00ea
Event: time 1632204133.108068, type 1 (EV_KEY), code 114 (KEY_VOLUMEDOWN), value 1
Event: time 1632204133.209297, -------------- SYN_REPORT ------------
Event: time 1632204133.513182, type 4 (EV_MSC), code 4 (MSC_SCAN), value c00e9
Event: time 1632204133.513182, type 1 (EV_KEY), code 115 (KEY_VOLUMEUP), value 1
Event: time 1632204133.614496, -------------- SYN_REPORT ------------
Event: time 1632204133.917963, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0192
Event: time 1632204133.917963, type 1 (EV_KEY), code 140 (KEY_CALC), value 1
[/code]

The built-in keyboard and a DELL keyboard I have at work (connected via USB) do not present the same issue.

Steps to reproduce:
Connect iqunix keyboard (no difference between Bluetooth or wire via usb-c) and hit any F-key.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 14 October 2021, 21:49 GMT
Reason for closing:  Won't fix
Additional comments about closing:  2021-09-22: A task closure has been requested. Reason for request: the keyboard wrongly uses the driver hid-apple this didn't happen in the LTS kernel version where it uses hid-generic. Don't think this problem is a real bug.
Comment by Andrea (Snaporaz) - Tuesday, 21 September 2021, 22:39 GMT
the keyboard wrongly uses the driver hid-apple this didn't happen in the LTS kernel version where it uses hid-generic
Comment by Andreas Radke (AndyRTR) - Friday, 24 September 2021, 19:59 GMT
Shouldn't this get fixed in the latest kernel? Be aware lts kernel will some day move to a new major version as well.
Comment by Andrea (Snaporaz) - Tuesday, 28 September 2021, 19:22 GMT
I just installed the latest kernel (15.14.8) and have the same issue. I can avoid the problem by blacklisting hid-apple.

I'm not sure this is of any help, but in module.alias I have "alias hid:b0005g*v000005ACp0000024F hid_apple" which is cousing the problem (while in the LTS is missing)
Comment by Jan Alexander Steffens (heftig) - Tuesday, 28 September 2021, 21:32 GMT
Yeah, your keyboard identifies as an Apple Aluminium USB Keyboard (vendor 05ac, product 024f). These IDs were assigned to hid-apple for USB devices since 2011.

What changed recently is that the same IDs were assigned to hid-apple for Bluetooth as well, so these pretending-to-be-Apple keyboards now behave identically whether you connect them via USB or BT.

Loading...