Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72154 - [sudo] sudo 1.9.8-1 segfaults when running with sssd

Attached to Project: Arch Linux
Opened by Nigel Kukard (nkukard) - Thursday, 16 September 2021, 15:36 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 03:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have 8 systems I just updated to sudo 1.9.8-1 and all are segfaulting when running sudo and sssd.


Additional info:
* package version(s): 1.9.8-1

* config and/or log files etc.
[ 56.360844] sudo[2105]: segfault at 8 ip 00007f78af03372a sp 00007ffdfe42abd0 error 4 in sudoers.so[7f78aeff8000+5e000]
[ 358.525901] sudo[3022]: segfault at 8 ip 00007fd23fbce72a sp 00007ffc6a158940 error 4 in sudoers.so[7fd23fb93000+5e000]
[ 429.123798] sudo[3255]: segfault at 8 ip 00007f0c46ae272a sp 00007ffdeb628cb0 error 4 in sudoers.so[7f0c46aa7000+5e000]
[ 451.748556] sudo[3292]: segfault at 8 ip 00007f253f2f272a sp 00007fffbe4ac900 error 4 in sudoers.so[7f253f2b7000+5e000]
[ 559.698998] sudo[3511]: segfault at 8 ip 00007f1891bda72a sp 00007ffec42b1c20 error 4 in sudoers.so[7f1891b9f000+5e000]
[ 741.884927] sudo[4017]: segfault at 8 ip 00007f53c116572a sp 00007ffd4e798710 error 4 in sudoers.so[7f53c112a000+5e000]

I'm having trouble getting a core dump though. Probably because its a SUID binary.

I am using sssd, removing "sudoers: files sss" from /etc/nsswitch.conf works around the issue.


Steps to reproduce:
Configure sssd
Add "sudoers: files sss" to /etc/nsswitch.conf
Run sudo
Get segfault



This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 17 September 2021, 03:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  sudo 1.9.8.p1-1
Comment by Brett Dutro (SmashedSqwurl) - Thursday, 16 September 2021, 16:01 GMT
I get the same error in 1.9.8-2 as well.
Comment by Nigel Kukard (nkukard) - Thursday, 16 September 2021, 16:51 GMT
I tested the fix in 1.9.8-2 with the same result
Comment by Ryan S. (simpoltin) - Thursday, 16 September 2021, 16:56 GMT
I can confirm my desktop and laptop both exhibit the same. Running sssd against FreeIPA.

sudo 1.9.8-2
sssd 2.5.2-1
linux-lts 5.10.64-1
plasma-desktop 5.22.5-1

Can provide further info if needed.
Comment by Nigel Kukard (nkukard) - Thursday, 16 September 2021, 17:09 GMT
I filed an upstream bug report too...
https://bugzilla.sudo.ws/show_bug.cgi?id=994
Comment by Nigel Kukard (nkukard) - Thursday, 16 September 2021, 17:15 GMT
Confirmed now in upstream bug report on Centos :)
Comment by Nigel Kukard (nkukard) - Thursday, 16 September 2021, 17:39 GMT

Loading...