Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72153 - [thunar] 4.16.9-1 segmentation fault

Attached to Project: Arch Linux
Opened by Michael (ZeroBeat) - Thursday, 16 September 2021, 13:33 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 18:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since update to 4.16.9 thunar crashes very often after pressing ctrl+a followed by ctrl+c
[ 4337.734344] Thunar[1010]: segfault at 3dca0003b224 ip 00007fbf4fc2be3a sp 00007fff40025e80 error 4 in libgobject-2.0.so.0.6800.4[7fbf4fc07000+2f000]
[ 4337.734365] Code: 00 48 8d 05 68 f0 ff ff 48 89 43 28 48 8d 05 ad f0 ff ff 48 89 43 30 5b c3 0f 1f 80 00 00 00 00 53 48 85 ff 0f 84 56 01 00 00 <48> 8b 07 48 89 f9 48 89 c2 48 83 e2 fc 48 3d fc 03 00 00 76 61 48
No more information available.

I assume that the issue is not related to libgobject, because thunar 4.16.8 is working fine.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 17 September 2021, 18:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  thunar 4.16.9-2
Comment by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 04:31 GMT
See if you can get a backtrace using this build (do a `killall Thunar` after installing it):

https://pkgbuild.com/~foutrelis/thunar-4.16.9-unstripped/

I've had a similar crash about 3 days ago, but we need to figure out how to reliably reproduce this in order to report it upstream.
Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 06:35 GMT
Ok, let's hunt for the bug.
Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 10:31 GMT
Maybe it could be a good idea to recompile thunar with symbols.
Comment by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 10:49 GMT
See my first comment for a thunar package with debug symbols. Install that, kill any thunar daemons running in the background (killall Thunar), wait for thunar to crash during normal use and then check if coredumpctl shows a useful backtrace.

A reliable way to reproduce the crash would be even more useful than the trace, but it could be harder to pinpoint the exact steps to make it crash.
Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 11:13 GMT
I'm running your version - but haven't noticed that is was compiled with debug symbols.

Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 11:34 GMT
When running thunar inside gdb, everything is working fine and I can't reproduce this issue.
Do you have any ideas why this happens?


Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 11:35 GMT
Ok, please forget my last commet. I got it:

(thunar:20714): GLib-GObject-CRITICAL **: 13:34:13.795: g_type_interface_peek: assertion 'instance_class != NULL' failed

Thread 1 "thunar" received signal SIGSEGV, Segmentation fault.
0x00005555555d6f75 in thunar_view_reload (view=0x5555559125d0, reload_info=0) at thunar-view.c:267
267 thunar-view.c: file not dound

Comment by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 11:45 GMT
Thanks for the crash info. Seems an upstream developer has come across this too, though he is using thunar from master and not a released version. It could be that a related commit was backported to 4.16.x from master. I added a comment in case these crashes have the same cause (which is likely).

https://gitlab.xfce.org/xfce/thunar/-/issues/192#note_36951
Comment by Michael (ZeroBeat) - Friday, 17 September 2021, 11:57 GMT
For me it looks like a race condition between two threads.
Comment by Evangelos Foutras (foutrelis) - Friday, 17 September 2021, 17:29 GMT
Tracked upstream at https://gitlab.xfce.org/xfce/thunar/-/issues/653 -- A suspect commit has been identified.

Loading...