Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72146 - custom password prompt fails with recent sudo update

Attached to Project: Arch Linux
Opened by mike (mbalajew) - Wednesday, 15 September 2021, 23:01 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 16 September 2021, 04:09 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Custom password prompt (i.e. "-p" option) fails on sudo version 1.9.8-1. This option works after reverting back to previous version, 1.9.7.p2-1

Steps to reproduce: run sudo with custom prompt option, for example:
sudo -p "blah" ls

Command returns this error:
sudo: (null): option "passprompt_override" does not take a value
sudo: error initializing audit plugin sudoers_audit


This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 16 September 2021, 04:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  sudo 1.9.8-2 (in [testing])
Comment by David Thurstenson (thurstylark) - Thursday, 16 September 2021, 00:20 GMT
Looks like it's already been addressed upstream: https://bugzilla.sudo.ws/show_bug.cgi?id=993
Comment by mike (mbalajew) - Thursday, 16 September 2021, 01:00 GMT
Yup. Tried the patch, and the bug is gone.

Loading...