AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
https://wiki.archlinux.org/title/Bug_reporting_guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://gitlab.archlinux.org/archlinux/aurweb/
Tasklist

FS#7212 - Community DB not updating - DB schema issues

Attached to Project: AUR web interface
Opened by Ray (ataraxia) - Saturday, 19 May 2007, 15:01 GMT
Last edited by Paul Mattal (paul) - Tuesday, 26 June 2007, 12:10 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To Paul Mattal (paul)
Simo Leone (neotuli)
Architecture All
Severity High
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Apparently, repo DBs aren't getting updated (on central, not just mirrors). It happened to current, and it's ongoing with community.

See this forum thread: http://bbs.archlinux.org/viewtopic.php?pid=251767#p251767
This task depends upon

Closed by  Paul Mattal (paul)
Tuesday, 26 June 2007, 12:10 GMT
Reason for closing:  Fixed
Comment by Simo Leone (neotuli) - Saturday, 19 May 2007, 16:32 GMT
This is being caused by a db-enforced limit of 32 character package names. It seems stuff goes real haywire if you exceed that limit (greeeat). I don't have time to really take a good look at this until sunday night.
Comment by Hussam Al-Tayeb (hussam) - Sunday, 20 May 2007, 14:26 GMT
or just rename the package that exceeds the 32 character limit.
Comment by Andrew Fyfe (space-m0nkey) - Friday, 25 May 2007, 19:37 GMT
What's the status on this problem?
Comment by Roman Kyrylych (Romashka) - Friday, 25 May 2007, 19:45 GMT
still does not update
-rw-rw-r-- 1 1001 101 264927 2007-05-24 06:36 community.db.tar.gz
Comment by Delete Me (steve-e) - Saturday, 09 June 2007, 21:46 GMT
Still outdated.
Comment by Mateusz Jędrasik (imachine) - Saturday, 09 June 2007, 21:48 GMT
I'd just like to mention it's the same story for arch64. it seems to update okay now on arch32, but the arch64 community db file is still on, hmm, 26th of may...

So it could be that whatever fixed the i686 community db file to update itself properly might fix the arch64 repos, as the breakage seems to have occured about the same time (give a day or two for arch64 repos being a bit behind).

If there's anything one could do, i.e. investigate something somehow, I'd gladly help out.

Regards,

//m.
Comment by Delete Me (steve-e) - Saturday, 09 June 2007, 21:48 GMT
Just noticed that 32bit community.db.tar.gz is up to date, but the 64bit community.db.tar.gz file is dated 26 May 2007.
Comment by Mateusz Jędrasik (imachine) - Monday, 11 June 2007, 20:04 GMT
Could anyone confirm working on this, or any work being done? It's somewhat frustrating to not know whether the bug is even reviewed, it's a pretty serious issue.

I don't know how the devs do it here, but ofcourse if you rather spend your time on fixing issues and therefore don't type much here that's more than okay by me. In fact, anything is okay, since you guys do a good job. It would be nice however had we known anything of the progress or suggestions, maybe there is some dev discussion on this issue already? Especially since a very similar, if not same, problem existed for 32bit, and has been aparently fixed.

Two heads' are better than one anyway, and if the community had some access to the aformentioned ongoing discussions, we may be able to help out too perhaphs.

Cheers,

//m.
Comment by Mateusz Jędrasik (imachine) - Monday, 11 June 2007, 20:05 GMT
Ok, I've just noticed now that two people are assigned to the project, disregard the first sentence in that case ;) Sorry.
Comment by Mateusz Jędrasik (imachine) - Monday, 25 June 2007, 03:38 GMT
Seems to update fine now. Someone preferably should investigate if it's fixed for good and close this maybe?

Cheers.

Loading...