Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72096 - Gtk+2 PKGBUILD Will Not Download from "git://git.gnome.org...

Attached to Project: Arch Linux
Opened by David C. Rankin (drankinatty) - Saturday, 11 September 2021, 01:56 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 11 September 2021, 07:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 11 September 2021, 07:56 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This was updated 4 years ago
Comment by David C. Rankin (drankinatty) - Saturday, 11 September 2021, 01:58 GMT
Arrgh! Sorry hit tab and return and this bug posted before I was ready.

The source in the PKGBUILD appears wrong. Attempting to build gtk2 from the current PKGBUILD results in:

makepkg -o
==> Making package: gtk2 2.24.31-1 (Fri 10 Sep 2021 08:30:22 PM CDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning gtk+ git repo...
Cloning into bare repository '/home/david/arch/pkg/asp/gtk2/gtk+'...
fatal: unable to connect to git.gnome.org:
git.gnome.org[0: 8.43.85.13]: errno=Connection refused
git.gnome.org[1: 8.43.85.29]: errno=Connection refused
git.gnome.org[2: 8.43.85.14]: errno=Connection refused
git.gnome.org[3: 2620:52:3:1:5054:ff:fede:8714]: errno=Network is unreachable
git.gnome.org[4: 2620:52:3:1:5054:ff:fedd:5ad0]: errno=Network is unreachable
git.gnome.org[5: 2620:52:3:1:5054:ff:fe0d:ee0f]: errno=Network is unreachable

==> ERROR: Failure while downloading gtk+ git repo
Aborting...


The current repository seems to be: git@gitlab.gnome.org:GNOME/gtk.git, not git://git.gnome.org/gtk+#commit=$_commit. Does the PKGBUILD need updating? I needed to build and include the docs which are currently removed.
Comment by David C. Rankin (drankinatty) - Saturday, 11 September 2021, 02:01 GMT
Since this bug got posted before I was ready, we can close it and I can write a new one if needed. Let me know.

Loading...