Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72094 - [kodi] libnsl was updated, now Kodi fails to run

Attached to Project: Community Packages
Opened by Uwe Sauter (UweSauter) - Friday, 10 September 2021, 16:14 GMT
Last edited by Antonio Rojas (arojas) - Friday, 10 September 2021, 16:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
libnsl was updated to 2.0.0-1 which now provides /usr/lib/libnsl.so.3 . Thus Kodi 19.1-6 fails to run with:

$ kodi
/usr/lib/kodi/kodi.bin: error while loading shared libraries: libnsl.so.2: cannot open shared object file: No such file or directory

This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 10 September 2021, 16:23 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partially updated system
Comment by John (graysky) - Friday, 10 September 2021, 16:17 GMT
I cannot confirm, kodi 19.1-1 and libnsl 2.0.0-1 co-exist on my system just fine.

Loading...