Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72079 - [libreoffice-fresh] 7.2.0-2 missing required dependency freetype2

Attached to Project: Arch Linux
Opened by Cadel Watson (cadelwatson) - Wednesday, 08 September 2021, 22:32 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 09 September 2021, 15:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After installing libreoffice-fresh 7.2.0-2 from extra, and running the libreoffice command, I get the following error:

/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/libskialo.so: undefined symbol: FT_Get_Paint

This is solved by installing the freetype2-2.11.0-3 package. Should this be added as a dependency to the libreoffice-fresh package?
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 09 September 2021, 15:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't do partial updates.
Comment by Antonio Rojas (arojas) - Thursday, 09 September 2021, 06:12 GMT
It is already in the dependency tree. Your problem was a partially updated system, which is not supported.
Comment by Phydoux (Phydoux) - Thursday, 09 September 2021, 09:53 GMT
I did an update and it fixed my error. Try updating with 'sudo pacman -Syu' and see if that fixes your issue.

Loading...